واسعارها - خطأ: فشل في بناء امتداد الأحجار الكريمة الأصلية-خطأ في تثبيت mysql2



كيف تعرف الحجر الكريم يعمل (2)

في بعض الأحيان تحتاج إلى تحديث مكتبة روبي الخاص بك، تشغيل هذا الرمز:

sudo gem update --system

https://src-bin.com

خطأ أثناء تشغيل تثبيت الحزمة

Installing mysql2 (0.3.11) with native extensions 
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.
...
Make sure that `gem install mysql2 -v '0.3.11'` succeeds before bundling.

عند تشغيل تأكد من أن gem install mysql2 -v '0.3.11' . أنا لا تزال تحصل على نفس الخطأ.


Answer #1

تم إصلاح الخطأ ..

حاول تثبيت هذه الحزم ..

سودو أبت-جيت إنستال ليبيسكلكلينت-ديف

سودو أبت-جيت إنستال بوندلر

بعد تثبيت بوندلر .. حاول مع

جوهرة تثبيت mysql2

عملها .. كول :)





bundler