javascript - سكريبت - جافا سكربت pdf



تتطلب() وظيفة في جافا سكريبت (2)

عند فتح وحدة تحكم كروم 14 والنوع ...

require (أو require() ، إذا كانت هذه المسائل)

أحصل على: ReferenceError .

وهذا يعني أن جافا سكريبت لا تملك هذه الوظيفة بشكل افتراضي، أليس كذلك؟ على الأقل على متصفحات الويب.

لماذا أتحدث عن ذلك؟
كنت في حاجة إلى محلل تخفيض السعر لجافا سكريبت.

ماذا أفعل؟
أنا، كما عادة، فتح جيثب والبحث عن ذلك. وكانت النتائج الأولى التي تطابق احتياجاتي هذا وهذا .

عادة (أنا لست جيدة مع جافا سكريبت) أنا تشمل البرنامج النصي أريد استخدام قبل بلدي التعليمات البرمجية باستخدام <script /> العلامة ومن ثم ... حسنا - استخدامه. ولكن هذه المرة أنا لا تحصل على ما يحدث ... :(

استخدام النص البرمجي رقم 1:

var input = "# Heading\n\nParagraph";
var output = require( "markdown" ).toHTML( input );
print( output );

الاستخدام للنص البرمجي رقم 2:

var marked = require('marked');
console.log(marked('i am using __markdown__.'));

من أين جاء ذلك require() من؟ شكرا في نصيحة! :)

https://src-bin.com


Answer #1

من الصفحة التي ترتبط بها:

طريقة بسيطة لاستخدامه مع كومونجس هو:

يبدو أن require يأتي من كومونجس


Answer #2

انها وسيلة لتشمل حزم node.js. لحسن الحظ، الحزمة الأولى التي ربطها، markdown-js ، هو ذكي جدا. فإنه يتحقق ما إذا كان يتم تضمينها كحزمة عقدة، وإذا لم يكن كذلك، سيتم تعيين كائن window.markdown إلى window.markdown . لذلك كل ما عليك القيام به هو تضمين هذا الملف في علامة <script> ويجب أن تكون قادرا على استخدام كائن markdown من النطاق العام.





require