ruby - একটি রুবি মণির একটি নির্দিষ্ট সংস্করণ ইনস্টল কিভাবে?



gem (4)

কমান্ড-লাইন gem টুল ব্যবহার করে, আমি কিভাবে একটি মণির একটি নির্দিষ্ট সংস্করণ ইনস্টল করতে পারি?

https://src-bin.com


Answer #1

Ruby জন্য 1.9+ কলোন ব্যবহার করুন ..

gem install sinatra:1.4.4 prawn:0.13.0

Answer #2

অন্যরা যেমন উল্লেখ করেছে, সাধারণভাবে gem install কমান্ডের জন্য -v flag ব্যবহার করুন।

আপনি আপনার gemspec থেকে একটি মণি কাটা পরে স্থানীয়ভাবে একটি মণি উন্নয়নশীল হয়:

$ gem install gemname-version.gem

অনুমান 0.8 সংস্করণ, এটি এই মত দেখতে হবে:

$ gem install gemname-0.8.gem

Answer #3

-v পতাকা ব্যবহার করুন:

$ gem install fog -v 1.8

Answer #4

gem install gemname -v versionnumber করার gem install gemname -v versionnumber

gem uninstall gemname -v versionnumber





gem