open - how to download android studio



Come faccio a "selezionare Android SDK" in Android Studio? (20)

A volte Android Studio si comporta in modo stupido e ha bisogno di una sorta di ripristino.

Vai al file settings.gradle che dovrebbe contenere include ':app'
cambiarlo per include ':ap' e sincronizzare.
dopo la sincronizzazione, cambiarlo per include ':app' nuovamente include ':app' .

Dovrebbe funzionare bene ora.

Dopo una corretta importazione di un progetto Eclipse-Android in "Android Studio 1.4", viene visualizzato l'errore

"Seleziona Android SDK"

quando faccio clic sul pulsante per eseguire l'applicazione nel simulatore, ma non riesco a trovare alcun modo per farlo.

Questa finestra di dialogo si apre quando faccio clic su "Esegui":

Questa è la finestra di dialogo "struttura del progetto":

Cosa dovrei fare ora?


Answer #1

Android Support Repository, Android SDK Platform 28 e altri 3 componenti SDK non sono stati installati, inserisci qui la descrizione dell'immagine

Come ho installato il file jdk e funziona bene in eclipse e voglio iniziare a lavorare in Android Studio, ma ogni volta che sto installando tutti i pacchetti di sdk manager non mostra alcuna installazione per favore aiutatemi.


Answer #2

Basta cambiare la versione degli strumenti di build in 25.0.3 .. e sincronizzare ora spero che possa aiutare ..


Answer #3

Dopo aver aperto il mio progetto in Android Studio, ho aperto la versione App del file build.gradle, situata nella cartella Gradle Scripts del progetto. Quando ho spostato il puntatore del mouse sul numero buildToolsVersion, è stata visualizzata una descrizione comandi che indica che è necessario aggiornare la versione di Android Build Tools (vedi screenshot). Ho modificato il valore di buildToolsVersion in quello identificato dall'errore (27.0.2) e il problema è stato risolto. L'errore originale (selezionare Android SDK) è scomparso e il progetto è stato compilato correttamente, ancora una volta. Sebbene questa soluzione sia stata menzionata in precedenza, i passi esatti sembravano mancare, quindi spero che questo chiarisca ogni dubbio. Immagino che la causa principale di questo problema sia il rilascio di una nuova versione degli strumenti di compilazione, ma Android Studio non ha attivato alcuna notifica per me, il che avrebbe indicato che avrei dovuto risolvere questo problema manualmente (dal momento che Android Studio non sembra avere il possibilità di aggiornare internamente questo file build.gradle), che lascia all'operatore il compito di trovare il problema e risolverlo.


Answer #4

Ho riscontrato questo problema su tutte le versioni di AS 3.0+. La sincronizzazione con Gradle non ha risolto il problema per me. La soluzione di András Klöczl era l'unica cosa che mi avrebbe permesso di fare un po 'di programmazione. Il problema era che, ogni volta che dovevo fare una sincronizzazione graduale, il problema ritornava. Quindi ho dovuto affrontare questo processo ogni volta che volevo apportare una modifica al mio build.gradle . Quello che alla fine ha funzionato per me è stato il downgrade della mia versione di 1.2.40 dalla 1.2.40 alla 1.2.30


Answer #5

Il commento di @Nisarg ha aiutato: "imposta l'ultima versione in Compile Versione Sdk"

Sono passato dall'API 8 all'API 23 e il messaggio di errore è scomparso.


Answer #6

In Android Studio 3 e versioni successive, sia per Windows, Mac e Linux :

File -> Sync Project with Gradle Files

Risolto!

Oppure puoi farlo con il tasto di scelta rapida :

Premi ⌘ + Maiusc + A ( Mac ) o Ctrl + Maiusc + A ( Windows, Linux ). Quindi pop-up un Edit-Text e scrivere "Sync Project with Gradle Files" . Quindi premere doppio clic sull'opzione.

Il tuo problema è stato risolto! Sincronizzerà il tuo file gradle con il tuo file di progetto, grazie.

**Immagine dello schermo : **


Answer #7

La soluzione più semplice per questo problema:

Per prima cosa assicurati che il tuo percorso sdk sia currect. Quindi chiudere il progetto corrente e nel menu di avvio Android fare clic su Importa progetto e selezionare il progetto da Explorer. Questo risolverà sempre il mio problema


Answer #8

Mi ha aiutato:

1. close project
2. remove .idea/ folder
3. select "import project (Gradle, Eclipse ADT, etc.)"

Ambiente:

Android Studio 3.1.3
OS Macos High Sierra 10.13.5

Altre risposte non funzionano per me.


Answer #9

Nel mio caso ho scaricato un repository git per un progetto Android. Il progetto ha richiesto la versione minima di sdk 21 e la versione di sdk di destinazione 27. Quando ho provato a eseguire il progetto mi ha dato "Seleziona errore SDK Android". Ho verificato di aver già scaricato i file SDK richiesti.

Per me la soluzione era "sincronizzare il progetto con Gradle Files"


Answer #10

Ora su Android Studio 3 e versioni successive, puoi provare a sincronizzare il progetto con un livello come:

File -> Sync Project with Gradle Files


Answer #11

Premi "Ctrl+shift+A" e nel pop-up EditText , scrivi "Sync Project with Gradle Files" . Dopo quel doppio clic sull'opzione visualizzata. Quindi sincronizzerà l' SDK file Gradle con il file di progetto.


Answer #12

Premi il primo pulsante di aggiornamento sulla scheda verticale Gradle in Android Studio sulla destra


Answer #13

Questo è il modo più semplice per risolvere questo problema:

  • Aggiungi una riga di commento al file gradle
  • Ti chiederà quindi di eseguire la sincronizzazione .
  • Fai clic su " Sincronizza ora "

Questo è tutto! Fatto.


Answer #14

Se stai utilizzando "APK profilo o debug ...", potresti riscontrare questo errore.

La mia soluzione è prima di controllare SDK per gli aggiornamenti nel gestore SDK: fare clic su "Modifica" sul lato destro della posizione dell'SDK e procedere per installare eventuali aggiornamenti:

Quindi ho fatto clic su "Logcat" nella parte inferiore di Android Studio e ho scoperto che devo anche configurare Android SDK, quindi scegli la piattaforma API Android più recente:

Successivamente, sono in grado di eseguire l'APK in Emulator.


Answer #15

Se viene fornito il tuo percorso SDK per Android e stai ancora affrontando questo problema, potrebbe essere perché il tuo studio Android non si è sincronizzato bene, anche se hai fatto clic sul link " Sincronizza ora ".

Quindi, per risincronizzarlo, vai al file gradle dell'app e apporta qualsiasi modifica o semplicemente dai uno spazio e ora sincronizza di nuovo. Funzionerà perfettamente.


Answer #16

Vai a: File> Struttura del progetto> Moduli -> app> Proprietà

scegliere: Compila la versione 'SDK' = API26 Build Tools Versione = 27.0.0 Compatibilità sorgente = 1.8 Compatibilità target = 1.8


Answer #17

Vai al file gradle.build e fai clic su Sincronizza ora O fai clic sull'icona Sincronizza progetto con il file Gradle

OPPURE Vai su Strumenti -> Android -> Sincronizza progetto con file Gradle


Answer #18

Vai a File >> ProjectStructure (⌘;). Questo aprirebbe questa finestra quindi selezionare il modulo dell'app . Quindi scegliere la versione di compilazione SDK. Scegli l'ultimo e fai clic su Applica.


Answer #19

FISSARE PER VERSIONI 3.1.2 O PIÙ RECENTI

Io e alcuni miei colleghi abbiamo affrontato lo stesso problema su AS 3.1.2 , ma una semplice sincronizzazione non ci ha aiutato. Per noi la soluzione era un po 'diversa:

  1. File -> Cache non valide -> Non valide
  2. File -> Chiudi progetto.
  3. Rimuovere il progetto dalla finestra di selezione del progetto AS.
  4. Esci da Android Studio
  5. Avviare AS e riaprire il progetto

CONSIGLI AGGIUNTIVI SE STA RISCONTRANDO QUESTO PROBLEMA

Alcuni di voi affrontano costantemente questo problema e questa "soluzione" lo risolve solo temporaneamente. Al momento in cui abbiamo iniziato a ricevere questo errore, abbiamo utilizzato Gradle wrapper 4.6 e Android Gradle Plugin 3.1.0, ma da allora siamo tornati al Gradle 4.4 e lo usiamo con l'ultimo plug-in Android Gradle, e non abbiamo riscontrato questo problema da allora.





eclipse-project-file