while - Xcodeのサポートファイルが見つからないiOS 12.2(16E227)



xcode beta download (3)

ここからデバイスサポートファイルをダウンロードしてください - あなたのXcodeバージョンがそれらを持っていないなら、 https://github.com/iGhibli/iOS-DeviceSupport/blob/master/DeviceSupport/12.2%20(16E226).zip (16E226).zip。 zipファイルを解凍して/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupportにコピーします。 16E266フォルダの名前を16E227に変更します。 XCodeを再起動します。

@ DavidHによって指摘されたように、これは私のために働きました。

私のデバイスはiOS 12.2を実行していますが、入手可能な最新のXcodeバージョン(ストアで、そして直接developer.appleから直接入手できます)では、そのiOSバージョンのサポートファイルが提供されないため、デバイス用にビルドできません。

これがXcodeからのエラーメッセージです。

そして私のXcodeビルドはmacOS Mojava v.10.14で動いています。

より最近のXcodeベータ版(またはXcode> Contents> Developer> Platforms> iPhoneOS.platform> DeviceSupportのサポートファイル)をダウンロードするための信頼できる場所は他にありますか、それともここに何か足りないのですか?


Answer #1

これが ソースファイルです

ダウンロードしたフォルダを /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupportに コピーした後、 Xcode 再起動して ください。 これがお役に立てば幸いです。


Answer #2

私は同じ問題を抱えていました。 https://github.com/iGhibli/iOS-DeviceSupport/blob/master/DeviceSupport/12.2%20(16E226).zip をダウンロードして /Applications/Xcode.app/Contents/Developer/に 貼り 付けよう としていました。 Platforms / iPhoneOS.platform / DeviceSupport パスですが、通常の流れではないと思います。 その後、私はオペレーティングシステムのアップデートをダウンロードすることはほとんどないことを思い出しました。 私の解決策は次のとおりです。

  1. このMacについて - > ソフトウェアアップデート (オペレーティングシステムのアップデート)に行きます。
  2. アップデートをダウンロードしてインストールすると、Xcodeをアップデートできるようになります。
  3. App Storeに 移動 - > xcode を検索 する と、Xcodeを正常に更新できます。

結論として: 私は私のmacOSオペレーティングシステム用のアップデートをインストールする必要がありました。





xcode