Ferramentas de Linha de Comando bash(git) não está funcionando-macOS Sierra final release candidate



terminal macos-sierra (4)

Acabei de atualizar do OS X 10.11 "El Capitan" para 10.12: "Sierra" , e quando tento acessar os comandos do git dentro de um terminal, recebo o seguinte erro:

xcrun: erro: caminho de desenvolvedor ativo inválido

(/ Library / Developer / CommandLineTools), faltando xcrun em:

/ Biblioteca / Desenvolvedor / CommandLineTools / usr / bin / xcrun

Por favor me ajude se alguém tiver solução.


Answer #1

Acabei de atualizar para o MacOS High Sierra versão 10.13.3 e tem o xcode existente. Minhas linhas de comando do git têm o mesmo problema. "$ xcode-select --install" funciona perfeitamente para mim.


Answer #2

Reinstale as ferramentas do desenvolvedor do Xcode

xcode-select --install

Answer #3

Eu corrigi este problema baixando e instalando o pacote 'Ferramentas de Linha de Comando (macOS sierra) para o Xcode 8' da Apple Developer Downloads .

Certifique-se de selecionar Command Line Tools (macOS 10.12) for Xcode 8 e não o do 8.1 beta, a menos que você tenha o Xcode 8.1 beta instalado.


Answer #4

Sozinho - xcode-select --install não funcionou para mim.

Teve que fazer todos os 3 passos:

  1. Baixar código X da loja de aplicativos (se não estiver presente na pasta Aplicativos)
  2. $ xcode-select - instalar
    uma. Pode ser necessário atualizar após a instalação usando softwareupdate na linha de comando. $ sudo softwareupdate -i "Ferramentas de linha de comando (macOS High Sierra versão 10.13) para Xcode-9.1"

  3. $ sudo xcodebuild -license





macos-sierra