ios - русском - apple developer program



Произошла ошибка при загрузке в iTunes Store (8)

Если вы не можете загрузить приложения в Apple и установить обновление JavaOSX (3 апреля 2012 г.), это может помочь вам восстановить свою способность загружать приложения:

Вы можете обойти эту проблему путем повторного создания старых символических ссылок Java 1.5:

cd /System/Library/Frameworks/JavaVM.framework/Versions
sudo ln -s CurrentJDK /System/Library/Frameworks/JavaVM.framework/Versions/1.5
sudo ln -s CurrentJDK /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0

Редактировать 5 октября 2012 г. Oracle Java 7

Разрабатывая комментарий Хэкмонфорда ниже.

Это точное сообщение об ошибке также происходит с установленным пакетом Oracle SE 7 1.7.0_10. Чтобы разрешить это, откройте «Предпочтения Java» и либо измените порядок использования Java SE SE 6, либо отключите Java 7 от Oracle при отправке в магазин приложений. Проверьте свои изменения, открыв терминал:

prince$ java -version
java version "1.6.0_35"

https://src-bin.com

Нам действительно нужна помощь в этом:

Мы сражались со всем Apple Mumbo-Jumbo в течение последних двух месяцев и, похоже, не можем получить APP на APPStore ...

Прямо сейчас моя проблема заключается в том, что после проверки компиляции ARCHIVE и обмена ею .. в процессе отправки я получаю -

«Произошла ошибка при загрузке в iTunes Store»

Я действительно не знаю, что я делаю неправильно, и, похоже, не нашел НИЧЕГО в Интернете, который решает проблему ...

С этим я уже полчаса уже больше недели ... Я пробовал:

  • Создание нового профиля распространения для подписи кода.

  • Проверка параметров цели снова и снова.

  • Изменение режима FTP с пассивного на непассивный

  • Подключение из разных сетей

  • Переустановка Xcode4

  • некоторые другие работы, такие как Загрузка приложения Loader (еще не установили его, но я не знаю, должен ли я)

Пожалуйста, помогите нам, как вы думаете, может быть проблема?

благодаря

Hernan


Answer #1

Моя mbp теперь запускает Xcode4.2 (4D199) на Lion, я установил последнюю версию java для Lion. И, наконец, я рассмотрел этот вопрос.

Многие ребята сказали, что он может использовать старое приложение Application Loader для загрузки приложений. поэтому я предполагаю, что проблема заключается в последнем приложении Application Loader (2.4.1 (190)), и факт сказал мне, что я прав

Okie, короче говоря: вот решение:

1. Я надеюсь, что вы, ребята, не удалите старый Xcode (4.1). Мы должны забрать приложение Application Loader старой версии.

cd <Install Xcode app>/Contents/Resources/Packages
cp ApplicationLoader.pkg ~/Desktop/

Теперь вы получаете пакет ApplicationLoader.

2.Установите старый. Советы: вы можете удалить последнее приложение Application Loader по пути: /Developer/Applications/Utilities/ или просто переделать его.

Это все.

Надеюсь, что этот способ может помочь вам и насладиться новым Xcode4.2. Также надеюсь, что разработчик apple может увидеть эту проблему и протестировать последнее приложение Application Loader.


Answer #2

На этой неделе я столкнулся с этой проблемой и установил обновление Java для OS X Lion 2012-002, и проблема была устранена. Сброс разрешений на диск не повлиял.


Answer #3

Немного поздно, я знаю, но для тех, у кого еще есть эта проблема. Посмотрите в файл журнала /var/log/system.log. В моем случае проблема заключалась в том, что сценарий iTMSTransporter (используемый Организатором при загрузке файла) использовал «awk», и мне пришлось заменить его «/ usr / bin / awk».

Полностью решена моя проблема.

Y.


Answer #4

Ниже приведены шаги по устранению этой проблемы:

Для начала я установил Oracles Java 1.7 JDK, который был действительно запутанным.

Пошел в Finder> Приложения и ввел в поле поиска - JavaAppletPlugin.plugin

Щелкните правой кнопкой мыши и удалите в корзину.

Проверка в терминале для версии Java по-прежнему показала Java 1.7

my-imac: ~ my $ java -версия

java-версия "1.7.0_07"

Java (TM) SE Runtime Environment (сборка 1.7.0_07-b10)

Java HotSpot (TM) 64-разрядная серверная VM (сборка 23.3-b01, смешанный режим)

1. Finder> Library> Java> JavaVirtualMachines показал 1.7 SDK (обратите внимание на точное имя каталога)

На всякий случай что-то пошло не так, я скопировал папку 1.7 SDK на свой рабочий стол, прежде чем делать следующий пункт

2. В терминальном типе

cd / Library / Java / JavaVirtualMachines

3. Теперь вы должны быть в этом каталоге

sudo rm -rf jdk1.7.0_06.jdk (или любое точное имя каталога находится на шаге 1).

Возможно, вам потребуется ввести пароль администратора

Теперь каталог должен быть удален, и вы можете проверить его в

java -version

Mine теперь показал «Java 1.6_xxx»

Пошел в Xcode Organizer и без проблем отправил мое приложение в магазин iTunes. Ого, ого-го!


Answer #5

Просто обновите последнюю версию JAVA на своем Mac Software Update.


Answer #6

У меня также была проблема JavaVM / JRE. Я установил предварительный просмотр JDK 7 из Oracle и перепутал процесс загрузки, который сообщил мне, что «Ошибка произошла при загрузке в iTunes Store».

Быстрая проверка /var/log/system.log (например, использование хвоста в терминале: tail -n 100 /var/log/system.log ) вызвало следующее сообщение об ошибке:

Требуются Java 1.5, 1.6 или 1.7. В настоящее время java является стандартной версией java. Пожалуйста, обновите.

Я установил MacOS Preview JDK 7 прямо из Oracle. Чтобы устранить эту проблему, просто запустите приложение «Параметры Java» в «Утилиты» и снимите флажок JDK 7 с Oracle. Конечно, у вас должна быть альтернативная JRE от Apple. Посмотрите на скриншот, как выглядит моя конфигурация. Загрузка теперь работает для меня.

Странно, что Oracle JDK не признан Apple Java 1,7. Это похоже на ошибку.

UPDATE: инструмент GUI был удален из MacOS. Теперь единственным решением, которое я знаю, является удаление папки JDK 1.7 вручную. См. Документы JDK 7, как это сделать:

Перейдите в / Library / Java / JavaVirtualMachines и удалите каталог, имя которого соответствует следующему формату:

/Library/Java/JavaVirtualMachines/jdk<major>.<minor>.<macro[_update]>.jdk

Например, чтобы удалить 7u6:

% rm -rf jdk1.7.0_06.jdk


Answer #7

Это снова произошло.
Для пользователей OSX 10.8.2 (не имеет предпочтения Java) единственный способ исправить это - удалить oracle jdk.

cd /Library/Java/JavaVirtualMachines
sudo rm -rf jdk1.7.0_09.jdk/




itunes-store