flex - success - vue js event calendar



Ошибка переноса Flex 3 на Flex 4 (2)

Я импортировал проект Flex 3 в Flex 4 и удалил все ошибки и предупреждения, перечисленные в проблемных окнах Flex 4.

У меня возникает следующая ошибка в Flex 4 при запуске приложения.

Что может быть причиной этого?

Error: Compatibility version has already been read.
    at mx.core::FlexVersion$/set compatibilityVersion()[E:\dev\4.x\frameworks\projects\framework\src\mx\core\FlexVersion.as:254]
    at mx.core::FlexVersion$/set compatibilityVersionString()[E:\dev\4.x\frameworks\projects\framework\src\mx\core\FlexVersion.as:301]
    at _Screen1Module_mx_core_FlexModuleFactory()

Эксперты, пожалуйста, помогите мне в этом.

Большое спасибо


Answer #1

Тот, у кого такая же проблема, обнаружила его среду FLEX_HOME, переменная все еще указывала на flex 3 sdk.


Answer #2

Вот ответ.

Проблема возникла при попытке загрузить модули в flex. Таким образом, в основном я включил пространства имен

xmlns:fx="http://ns.adobe.com/mxml/2009" 
xmlns:s="library://ns.adobe.com/flex/spark" 
xmlns:mx="library://ns.adobe.com/flex/mx"

а также заменили <mx:Component> , <mx:Style> на их соответствующие <fx:....>

И это решило проблему.